What do you need help with?

EPASS Pay Exception Error When Processing Payments

Issue:

When attempting to process a payment in EPASS, the following error message appears:

 

EPASS Payment Processing
Exception in
ePASSPayment.PaymentProcessingEPA.SetRequestData:
Failed to set request data. Type of data: Payment – 
Exception in GetInvoiceData:
Failed to get invoice data. – 
Could not load file or assembly
’InterSystems.Data.CacheClient, Version=4.0.0.0,
Culture = neutral, PublicKeyToken=xxx’ or one
of its dependencies. The system cannot find the file specified.
[OK]

 

This error indicates that the workstation cannot load the required InterSystems Cache Client DLL, which EPASS needs to communicate with the database during payment operations.


Cause:

The error occurs because the workstation does not have the correct version of the InterSystems Cache Client installed.  EPASS specifically requires Cache 2016, which includes the assembly InterSystems.Data.CacheClient version 4.0.0.0. If this client is missing, outdated, incorrect, or corrupted, EPASS cannot load the necessary components.

 

Solution:
 

Install or reinstall the Cache 2016 client. Contact EPASS Support for assistance.

×
Select company

You are related to multiple companies. Please select the company you wish to login as.